Autor Wątek: [solved] Windows 10, openSUSE, Grub - windows nie działa poprawnie  (Przeczytany 377 razy)

0 użytkowników i 1 Gość przegląda ten wątek.

ksz

  • Początkujący
  • *
  • Wiadomości: 49
Witam

Mam problem z poprawnym działaniem Windowsa 10 na komputerze z openSUSE Leap42.3.

Komputer - laptop HP ProBook 650 G1 (nowy-używany, nie sprawdzałem go jak się zachowuje z windowsem 7 lub 8)
Dysk HDD (sda) wpięty w domyślne złącze.
Dysk SSD (sdb) wpięty w złącze M.2
Partycje MBR.

Mój podział dysków:

sda1 opensuse_HDD
sda2 linux_swap
sda3 /home
sda4 windows_D

sdb1 opensuse_SSD
sdb2 windosw_C

opensuse_HDD i opensuse_SSD to dwie oddzielne instalacje openSUSE. Domyślnie korzystam z tej z SSD. Wersja na HDD jest awaryjnie jak by mi padł dysk SSD ("chińczyk").

Windowsa używam od "wielkiego dzwonu" ale skoro jest to chciałbym, żeby działał jak należy.

Oba linuxy działają poprawnie tj.: działa wyłączanie, restart, uśpienia, itd. Problem jest z windowsem. Zaraz po instalacji windowsa (bez odbudowywania Gruba) działa on poprawnie. Może się wyłączać, restartować, poprawnie instalują się aktualizacje wymagające ponownego uruchomienia.
Jednaj jak tylko odbuduję Gruba (Grub2) windows zaczyna wariować. Sam system działa poprawnie podczas pracy. Restart wyłącza komputer i załadowywuje Gruba. Można wybrać jeden z 3 systemów i każdy z nich załaduje się poprawnie. Nie działa natomiast poprawnie, w windowsie, opcja "wyłącz" - system wyłącza się po czym po 2, 3 sekundach pojawia się pulpit logowania do konta. Aktualizacje nie wymagajace ponownego uruchomienia instalują się poprawnie, natomiast te, które wymagają ponownego uruchomienia zaczynają się aktualizować, komputer restartuje się, podczas wgrywania systemu instalacja jest kontynuowana ale kończy się informacją "Nie można ukończyć instalacji aktualizacji. Wycofywanie zmian..." Po czym komputer uruchamia się ponownie (do Gruba). Windows uruchamia się ponownie bez błędów, ale aktualizacje nie są zainstalowane. I tak w koło. A linuxy ciągle działają bez problemu.

Przeszukałem interneta ale nic mądrego nie znalazłem na ten temat.

Problem wydaje się być związany z programem rozruchowym. Próbowałem różnych konfiguracji programu rozruchowego w yascie ale bez efektów.

Próbowałem po kolei umiejscowienia programu rozruchowego w partycji głównej, MBR i partycji, którą sam wskazałem. Zawsze miałem ustawioną flagę aktywności dla partycji rozruchowej. Włączałem zapis standardowego kodu rozruchowego do MBRa. Żadna z kombinacji nie przyniosła pożądanego efektu.

Tak samo się działo jak miałem tylko dysku HDD, ale wtedy nie wnikałem głębiej w problem bo czekałem na SSD.

Jak poprawnie skonfigurować Gruba, żeby "naprawić" windowsa?
« Ostatnia zmiana: Maj 18, 2018, 07:53:50 pm wysłana przez ksz »

Stefan

  • Moderator
  • Maniak SUSE
  • *
  • Wiadomości: 2942
  • Moderator kuwety
Odp: Windows 10, openSUSE, Grub - windows nie działa poprawnie
« Odpowiedź #1 dnia: Maj 12, 2018, 07:01:51 pm »
To nie jest przypadłość gruba. Miałem podobnie na Windows 7 - jedyny system na hdd. Jedne aktualizacje instalował poprawnie, inne mu się wykładały i wyglądało to, wypisz wymaluj, jak u Ciebie.
X220: WXGA  i5-2520M 8GB DDR3 SSD:60GB OS:buster/sid || Pomiędzy prezentacją siebie, a reklamą istnieje zasadnicza różnica. Konta z linkami są usuwane

ksz

  • Początkujący
  • *
  • Wiadomości: 49
Odp: Windows 10, openSUSE, Grub - windows nie działa poprawnie
« Odpowiedź #2 dnia: Maj 13, 2018, 09:20:12 am »
Niestety nie testowałem windowsa jako jedynego systemu przez dłużej niż pół dnia, tak, że nie mogę stwierdzić czy przy kolejnych aktualizacjach by nie zachowywał by się jak teraz.
Na początku problemy z instalacją aktualizacji jakoś mi nie przeszkadzały i nie wnikałem w nie głębiej bo windowsa traktuję bardziej "skoro go mam to niech se będzie" ale raz potrzebowałem zainstalować niepodpisane sterowniki i okazało się, że nie mam jak wyłączyć sprawdzania podpisu sterowników.
Aby uruchomić windowsa w trybie bez sprawdzania podpisów sterowników należy podczas uruchamiania ponownego systemu przytrzymać klawisz shift i uruchamia się wtedy menu, gdzie mamy do wyboru: kontynuuj, rozwiąż problemy i wyłącz komputer. Mam tak tylko do odbudowania Gruba. Potem mam tylko opcję "wyłącz komputer".
Ostatnio była duża aktualizacja "April 2018 Update". Myślałem, że ona coś naprawi (wiem, wiem, oszukiwałem się). Dałem, żeby się aktualizował, ale kończyło się to tak jak zawsze. Po 2, 3 próbach postanowiłem zaktualizować z instalki z pendraka z uruchomionego windowsa. A ten coś pomielił, jakieś paski postępu doszły do końca i po ok 5 minutach wyrzucił informację: "Instalator systemu Windows 10. Niestety, mamy problem z określeniem, czy na Twoim komputerze można uruchomić system Windows 10. Zamknij Instalatora i ponów próbę." Jedyny system, który się siebie wypiera :) 
Podczas instalacji z bootowanego pendrajwa system nie daje możliwości aktualizacji a jedynie instalacji od nowa, choć przy tej operacji ostrzega, że jest tam wcześniejsza instalacja, i że zostanie ona przeniesiona do katalogu "Windows.old".
Powyższe skłania mnie do wniosków, że to jednak coś z opcjami rozruchowymi powoduje problemy z 'tożsamością" biednego windowsa.
Jak coś to podrzucę ten problem na jakieś forum windowsowe bo może to częstszy przypadek niekoniecznie związany z linuxem.

Stefan

  • Moderator
  • Maniak SUSE
  • *
  • Wiadomości: 2942
  • Moderator kuwety
Odp: Windows 10, openSUSE, Grub - windows nie działa poprawnie
« Odpowiedź #3 dnia: Maj 13, 2018, 12:25:14 pm »
pclab.pl/news77848.html

Windows 10 April 2018 Update powoduje problemy na komputerach z nośnikami SSD Intela
X220: WXGA  i5-2520M 8GB DDR3 SSD:60GB OS:buster/sid || Pomiędzy prezentacją siebie, a reklamą istnieje zasadnicza różnica. Konta z linkami są usuwane

ksz

  • Początkujący
  • *
  • Wiadomości: 49
Odp: Windows 10, openSUSE, Grub - windows nie działa poprawnie
« Odpowiedź #4 dnia: Maj 13, 2018, 12:43:38 pm »
Windows 10 April 2018 Update powoduje problemy na komputerach z nośnikami SSD Intela

Ale u mnie to się działo przed tą aktualizacją. A nawet zanim miałem dysk ssd. Myślałem tylko, że ona pomoże.
Mój dysk ssd to KingSpec a Microsoft nie może zepsuć czegoś o czego istnieniu nawet nie wie  :)

ksz

  • Początkujący
  • *
  • Wiadomości: 49
Odp: Windows 10, openSUSE, Grub - windows nie działa poprawnie
« Odpowiedź #5 dnia: Maj 16, 2018, 01:47:02 pm »
"Wyrzuciłem" na testy dysk ssd. Windowsa zainstalowałem na partycji sda4 i ciągle jak powyżej, czyli dopóki nie odbuduję gruba jest ok.
Dopytam na forum dla łindowsiarzy bo ich taka sytuacja może bardziej denerwować.

szwagier

  • Geeko's friend
  • Maniak SUSE
  • *
  • Wiadomości: 2934
Odp: Windows 10, openSUSE, Grub - windows nie działa poprawnie
« Odpowiedź #6 dnia: Maj 17, 2018, 05:38:05 am »
Może problemem jest instalacja windowsa na ostatniej partycji. U mnie nie stwarzał nigdy problemów ale zawsze instaluję go na pierwszej. Kiedyś pisano o tym że windows nie lubi innych partycji.
Mam 3 linuxy i windowsa, grub bardzo często nadpisywany - i żadnych problemów.
Moja propozycja dla HDD:
1 - windows
2 - linux
3 - home
4 - swap
SSD na M2 jako bootowalny i w jego MBR zainstaluj gruba.
« Ostatnia zmiana: Maj 17, 2018, 05:43:05 am wysłana przez szwagier »

ksz

  • Początkujący
  • *
  • Wiadomości: 49
Odp: Windows 10, openSUSE, Grub - windows nie działa poprawnie
« Odpowiedź #7 dnia: Maj 17, 2018, 12:56:25 pm »
Myślałem nad windowsem na pierwszej partycji, ale na susła przeznaczyłem kiedyś 30 GB a na windowsa 100 GB a po środku mam ponad 800 GB /home i żonglerka partycjami trochę mnie przeraża ale... czuję, że tak się skończy. Najpóźniej do końca łikensu postaram się to zrobić i pochwalę się efektami.

A co windowsa to od suse 10.x siedzę na linuxie jako głównym systemie i od tego czasu windows zajmuje zawsze ostatnią, czwartą, partycję na dysku. Z XP i 7 nie miałem problemu, ale i komputery były bez uefi i tego typu historii.

szwagier

  • Geeko's friend
  • Maniak SUSE
  • *
  • Wiadomości: 2934
Odp: Windows 10, openSUSE, Grub - windows nie działa poprawnie
« Odpowiedź #8 dnia: Maj 17, 2018, 02:58:45 pm »
Ja mam linuxy na dwóch SSD - jeden na M2 drugi na SATA. Trzeci jest na starym dysku HD razem z windowsem, bo jak ty bardzo rzadko używam windowsa. Praktycznie tylko do wgrywania romów na telefony.
Ale jest mi zawsze posłuszny, a też często zmieniam wersje - zwykle jakieś extrema.  :)

ksz

  • Początkujący
  • *
  • Wiadomości: 49
Odp: Windows 10, openSUSE, Grub - windows nie działa poprawnie
« Odpowiedź #9 dnia: Maj 17, 2018, 05:42:34 pm »
Gdzie masz zapisanego gruba i jakie opcje związane z mbr masz zaznaczone?

szwagier

  • Geeko's friend
  • Maniak SUSE
  • *
  • Wiadomości: 2934
Odp: Windows 10, openSUSE, Grub - windows nie działa poprawnie
« Odpowiedź #10 dnia: Maj 18, 2018, 05:55:55 am »
Grub siedzi na obydwu SSD a bootowanie przełączam w biosie. Zawsze instaluje się domyślnie, bez dodatkowych ustawień.
Na M2 jest leap 42.3 a na SATA Leap 15. Ale obojętnie z jakiego dysku bootuję bo przecież kolejność uruchamiania systemów można ustawić w grubie.
Jak będzie final 15 to go wrzucę na M2, a SATA będzie do testów.

ksz

  • Początkujący
  • *
  • Wiadomości: 49
Odp: Windows 10, openSUSE, Grub - windows nie działa poprawnie
« Odpowiedź #11 dnia: Maj 18, 2018, 07:53:24 pm »
Przeprowadzka Windowsa na pierwszą partycję wszystko naprawiła.

Myślałem, że nowsze edycje Windowsa lepiej będą sobie radzić z mulitbootem ale po raz kolejny się myliłem :)

Problem uważam za rozwiązany.
Dziękuję za pomoc.