Autor Wątek: [solved] XSP i mono  (Przeczytany 1514 razy)

0 użytkowników i 1 Gość przegląda ten wątek.

skullman

  • Początkujący
  • *
  • Wiadomości: 2
[solved] XSP i mono
« dnia: Luty 26, 2018, 12:38:14 am »
To mój pierwszy post na forum więc witam wszystkich. Na wstępie chciałbym zaznaczyć, że w "uniwersum" SuSE jestem całkowicie nowy i wydaje mi się ono dość egzotyczne. Problem mój jest dość mało linuksowy i nie wiem jak sobie z tym poradzić. Susełka wrzuciłem na lapka bo szukałem dobrego distro pod mono i to distro w jakimś starym poście polecali na stackoverflow.  Skoro już go mam i mam problem to chciałbym go rozwiązać. Otóż, niezależnie czy z prawami roota czy bez odpalam serwer XSP to się wysypuje w taki oto sposób:~> xsp
exception inside UnhandledException handler: The type initializer for 'System.Console' threw an exception.

[ERROR] FATAL UNHANDLED EXCEPTION: System.TypeInitializationException: The type initializer for 'System.Console' threw an exception. ---> System.TypeInitializationException: The type initializer for 'System.ConsoleDriver' threw an exception. ---> System.Exception: Magic number is wrong: 542
  at System.TermInfoReader.ReadHeader (System.Byte[] buffer, System.Int32& position) [0x00028] in <8e79b22bc5c74bcca8f3099bc7a2e0db>:0
  at System.TermInfoReader..ctor (System.String term, System.String filename) [0x0005f] in <8e79b22bc5c74bcca8f3099bc7a2e0db>:0
  at System.TermInfoDriver..ctor (System.String term) [0x00055] in <8e79b22bc5c74bcca8f3099bc7a2e0db>:0
  at System.ConsoleDriver.CreateTermInfoDriver (System.String term) [0x00000] in <8e79b22bc5c74bcca8f3099bc7a2e0db>:0
  at System.ConsoleDriver..cctor () [0x0004d] in <8e79b22bc5c74bcca8f3099bc7a2e0db>:0
   --- End of inner exception stack trace ---
  at System.Console.SetupStreams (System.Text.Encoding inputEncoding, System.Text.Encoding outputEncoding) [0x00007] in <8e79b22bc5c74bcca8f3099bc7a2e0db>:0
  at System.Console..cctor () [0x0008e] in <8e79b22bc5c74bcca8f3099bc7a2e0db>:0
   --- End of inner exception stack trace ---


Server stack trace:
  at Mono.WebServer.XSP.Server.RealMain (System.String[] args, System.Boolean root, Mono.WebServer.IApplicationHost ext_apphost, System.Boolean quiet) [0x007fa] in <881137d473b344d3a38c91e3d971fa95>:0
  at (wrapper remoting-invoke-with-check) Mono.WebServer.XSP.Server.RealMain(string[],bool,Mono.WebServer.IApplicationHost,bool)
  at (wrapper xdomain-dispatch) Mono.WebServer.XSP.Server.RealMain(object,byte[]&,byte[]&,string[],bool,bool)

Exception rethrown at [0]:
  at (wrapper xdomain-invoke) Mono.WebServer.XSP.Server.RealMain(string[],bool,Mono.WebServer.IApplicationHost,bool)
  at (wrapper remoting-invoke-with-check) Mono.WebServer.XSP.Server.RealMain(string[],bool,Mono.WebServer.IApplicationHost,bool)
  at Mono.WebServer.XSP.Server.RealMain (System.String[] args, System.Boolean root, Mono.WebServer.IApplicationHost ext_apphost, System.Boolean quiet) [0x007c2] in <881137d473b344d3a38c91e3d971fa95>:0
  at Mono.WebServer.XSP.Server.Main (System.String[] args) [0x00021] in <881137d473b344d3a38c91e3d971fa95>:0
Mam Tumbleweed i od kiedy wrzuciłem go na lapka to były już dwie aktualizacje serwerka ale jak widać nie dały żadnej poprawy. Jeśli nie można tego jakoś w miarę łatwo naprawić to może są jakieś inne repo albo backporty z działającą wersją?
« Ostatnia zmiana: Luty 28, 2018, 10:58:43 pm wysłana przez skullman »


skullman

  • Początkujący
  • *
  • Wiadomości: 2
Odp: [solved] XSP i mono
« Odpowiedź #2 dnia: Luty 28, 2018, 11:00:11 pm »
Działa. Mono mi działało normalnie, tylko xsp miał swoje fochy więc czytałem a raczej szukałem wątków na temat samego serwerka. Dzięki.