Autor Wątek: montowanie zaszyfrowanych dysków  (Przeczytany 2427 razy)

0 użytkowników i 1 Gość przegląda ten wątek.

ipos

  • SUSE Guru Apprentice
  • ***
  • Wiadomości: 323
montowanie zaszyfrowanych dysków
« dnia: Grudzień 24, 2017, 10:25:32 am »
Cześć,

mam taką konfigurację "od zawsze" - zaszyfrowaną partycję "archiwum", montowana na żądanie (hasło do zaszyfrowanej partycji + hasło roota).
Niestety na Mate przestało działać. Nie miałem czasu się tym zająć do tej pory ale jest trochę luźniej więc chcę to naprawić.

Wpis w /etc/fstab jest taki:

UUID=2ee99ba7-744c-4f89-b29f-6a8ce1b60713 swap                 swap       defaults              0 0
UUID=306168db-b0f7-47b5-bd96-3129e9802fc6 /                    ext4       acl,user_xattr        1 1
/dev/mapper/cr_ata-HGST_HTS725050A7E630_RCF50ACF0RE42N-part3 /home                ext4       noauto,acl,user_xattr,nofail 0 2
/dev/mapper/cr_ata-HGST_HTS725050A7E630_RCF50ACF0RE42N-part4 /mnt/archiwum        ext4       noauto,nofail         0 0
UUID=282a294a-dc60-4a41-a955-b6409cf54bc4 /mnt/dane            ext4       defaults              1 2


a w /etc/crypttab taki:


cr_ata-HGST_HTS725050A7E630_RCF50ACF0RE42N-part4 /dev/disk/by-id/ata-HGST_HTS725050A7E630_RCF50ACF0RE42N-part4 none       noauto


Niestety jeśli kiikam w Caja (manager plików) ikonkę zaszyfrowanego dysku (partycji) z archiwum, to wywala mi komunikat "Nie można zamontować zaszyfrowane dane o rozmiarze... Działanie zostało anulowane"

Jak zrebootuję system i wyklikam w Yaście > Montuj partycję > /mnt/dane > Nie montuj przy starcie systemu to po zatwierdzeniu w Yaście partycja montuje mi się w docelowym miejscu (Yast żąda hasła do zaszyfrowanej partycji). Po reboocie wszystko znów wraca do "normy" czyli nie montuje na żądanie.

Jeśli wywalę wpisy w /etc/crypttab to partycja montuje się w /var/media bez problemu ale na tym akurat mi nie zależy, bo mam swoje ścieżki, m.in. w sambie...

Ktoś, coś?

Dzięki i pozdrawiam świątecznie
Wrocław - Europejska Stolica Smogu

mastal

  • Moderator
  • SUSE Root
  • *
  • Wiadomości: 1926
Odp: montowanie zaszyfrowanych dysków
« Odpowiedź #1 dnia: Styczeń 07, 2018, 06:21:02 pm »
a gdzie dowody na to co piszesz. Logi systemowe myszy zjadły ?
1. Zapoznaj się ze stroną http://www.linux-tips-and-tricks.de/quickstart#English i wykonaj tam zawarte punkty
2. Przyślij wynik skryptu collectNWData.sh

ipos

  • SUSE Guru Apprentice
  • ***
  • Wiadomości: 323
Odp: montowanie zaszyfrowanych dysków
« Odpowiedź #2 dnia: Styczeń 25, 2018, 04:46:26 pm »
a gdzie dowody na to co piszesz. Logi systemowe myszy zjadły ?

Sory, że dopiero teraz piszę ale miałem inne problemy na głowie. No właśnie nie wiem, jak logi wydobyć, gdzie są w ogóle zapisywane logi od montowania dysków, wszak dyski montuję na żądanie w trakcie używania systemu albo i nie, ale nie przy starcie.

Wywaliło mi ostatnio komunikat o błędzie w bazie kluczy (jest na obrazku).

Problem częściowo rozwiązałem, bo robiłem porządki na dysku, grzebałem trochę przy rozmiarach partycji i ich umiejscowieniu i szyfrowałem dysk na nowo. Z takim dyskiem zaszyfrowanym spod Mate nie ma problemu, montuje się na żądanie. Problem był/jest z dyskami/partycjami szyfrowanymi pod inną dystrybucją/innym DE.

Wrocław - Europejska Stolica Smogu

ipos

  • SUSE Guru Apprentice
  • ***
  • Wiadomości: 323
Odp: montowanie zaszyfrowanych dysków
« Odpowiedź #3 dnia: Styczeń 27, 2018, 12:07:31 pm »
Jednak nie działa, jeśli przez Yasta wskażę żądany punkt montowania, to wyskakuje komunikat o problemie z bazą kluczy. Dzieje się to w momencie, jak w Caja klikam na zaszyfrowane partycje celem podmontowania. Jak zmienię przez Yasta (albo ręcznie zahaszuję wpisy w fstab) na "Nie montuj partycji" i potem klikam w Caja, to się ładnie montują w /var/run/media/ipos (oczywiście po monicie o hasła).

Problem jest - wg mnie - po stronie DE
Wrocław - Europejska Stolica Smogu

szwagier

  • Geeko's friend
  • Maniak SUSE
  • *
  • Wiadomości: 2963
Odp: montowanie zaszyfrowanych dysków
« Odpowiedź #4 dnia: Styczeń 27, 2018, 02:30:30 pm »
Od wersji 42.2 Yast nie potrafi zamontować nawet zwykłych dysków. W 42.1 jeszcze to działało.
Ja do montowania używam programu gnome-disks i ten działa perfekcyjnie.
Możesz wypróbować.  ;)

ipos

  • SUSE Guru Apprentice
  • ***
  • Wiadomości: 323
Odp: montowanie zaszyfrowanych dysków
« Odpowiedź #5 dnia: Styczeń 27, 2018, 03:08:02 pm »
Muszę wypróbować :) Ja już ściągnąłem Fedorę ;) Jak najlepiej zrobić kopię systemu (Opensuse) żeby łatwo przywrócić, jak mi się Fedora nie spodoba? Clonezilla to ostatnia rzecz, na której się zatrzymałem :D
Wrocław - Europejska Stolica Smogu

szwagier

  • Geeko's friend
  • Maniak SUSE
  • *
  • Wiadomości: 2963
Odp: montowanie zaszyfrowanych dysków
« Odpowiedź #6 dnia: Styczeń 27, 2018, 03:28:03 pm »
Ja do robienia kopii używam Acronisa (bootowalny z CD) - jeszcze mnie nie zawiódł.
A od Fedory na pewno lepszy jest Mint. Wydaje mi się że Mint z cinnamonem to najlepszy obecnie linuch.
A nawet z KDE działa sprawniej od suska.

ipos

  • SUSE Guru Apprentice
  • ***
  • Wiadomości: 323
Odp: montowanie zaszyfrowanych dysków
« Odpowiedź #7 dnia: Styczeń 28, 2018, 07:28:11 am »
Testowałem Minta ale na KDE się sypał, na cynamonku nie poradziłem sobie z tymi moimi szyfrowanymi partycjami - instalator tego nie ogarnia. Niestety jedyny, który to potrafi jest suskowy ;) Ale Mate mi się przestało podobać - problem z montowaniem dysków, a do tego jak uruchomię dropboksa, to mi się sam wcina do menu startowego, mimo że w dropsie mam ustawione, żeby tego nie robił.

Siedziałem kiedyś na Fedorze i nie podobał mi się zbyt częsty cykl wydawniczy, co pół roku....

Edyta:
Fedora oferuje - oprócz standardowego Gnome - także KDE, LXDE czy cynamonka. Na tego się chyba skuszę...
« Ostatnia zmiana: Styczeń 28, 2018, 11:43:07 am wysłana przez ipos »
Wrocław - Europejska Stolica Smogu

ipos

  • SUSE Guru Apprentice
  • ***
  • Wiadomości: 323
Odp: montowanie zaszyfrowanych dysków
« Odpowiedź #8 dnia: Grudzień 25, 2018, 10:52:39 pm »
No i rozwiązałem swój problem sprzed roku z montowaniem szyfrowanych dysków - nie działały moje stare konfigi na fstab i crypttab, nie pomagało rzeźbienie z palca w terminalu ani przez Yast2... Zacząłem czytać podręczniki i wklejać polecenia w terminal i wszystko psu w ... budę :)

A wystarczyło wejść w narzędzie Dyski i poustawiać hasła i punkty montowania...

Tak to jest, jak człowiek nie musi rano do roboty wstawać :)

A na marginesie - Yast2 coraz mniej się przydaje - szyfrowanie zrobiłem innym programem, miniDLNA trzeba rzeźbić w pliku, firewala na Leap15 nie ustawisz...
Wrocław - Europejska Stolica Smogu

szwagier

  • Geeko's friend
  • Maniak SUSE
  • *
  • Wiadomości: 2963
Odp: montowanie zaszyfrowanych dysków
« Odpowiedź #9 dnia: Grudzień 26, 2018, 08:03:18 am »
Cytuj
A wystarczyło wejść w narzędzie Dyski i poustawiać hasła i punkty montowania...
Ja tego narzędzia używam od czasu wydania Leap 42, bo od tego czasu Yast nie nadaje się do montowania partycji.

marcinz

  • Global Moderator
  • SUSE Guru
  • *
  • Wiadomości: 682
  • No kabooom no! OpenSuse 15
Odp: montowanie zaszyfrowanych dysków
« Odpowiedź #10 dnia: Grudzień 27, 2018, 06:13:56 am »
A możecie podać dokładnie nazwę programu do dysków ?
By ustawić partycje. YaST2 słabo działa pod tym względem
Lapek rodziców: ASUS K50IJ-SX151 OpenSUSE 15.0
Stacjonarny: R.I.P
Lapek własny: Lenovo Z50-75 z win 8.1 oraz OpenSUSE Leap 15.0

ipos

  • SUSE Guru Apprentice
  • ***
  • Wiadomości: 323
Odp: montowanie zaszyfrowanych dysków
« Odpowiedź #11 dnia: Grudzień 27, 2018, 07:10:11 am »
Disks gnome-disk-utility 3.26.2 - taka wersja jest u mnie w Mate. To chyba standardowe narzędzie w gnome i gnomopodobnych klonach
Wrocław - Europejska Stolica Smogu