Autor Wątek: Błąd MPlayer/mpv po aktualizacji Leap 42.2 => 42.3  (Przeczytany 2665 razy)

0 użytkowników i 1 Gość przegląda ten wątek.

klatu

  • Początkujący
  • *
  • Wiadomości: 11
Błąd MPlayer/mpv po aktualizacji Leap 42.2 => 42.3
« dnia: Listopad 20, 2017, 02:59:03 pm »
Cześć.
Podkusiło mnie zobaczyć co się stanie jak zamienię Leap 42.2 na 42.3.
Aktualizację przeprowadziłem offline z pendrajwa.
System działa poprawnie ale musiałem ponownie dodać repozytoria pacmana.
Problem polega na tym, że nie działa mi SMPlayer. Program się uruchamia ale niczego nie może odtworzyć.
Komunikat błędu: "MPlayer/mpv nieoczekiwanie zakończył pracę. Kod wyjścia: 1"
Dodam tylko że mpv działa.

Domyślam się, że to błahostka, ale dopiero przesiadam się na linuksa i nie wiem od której strony się za to zabrać.
Ponowna instalacja programu nic nie dała.

Marcysia_Z

  • Geeko's friend
  • SUSE Guru
  • *
  • Wiadomości: 868
Odp: Błąd MPlayer/mpv po aktualizacji Leap 42.2 => 42.3
« Odpowiedź #1 dnia: Listopad 20, 2017, 03:17:38 pm »
Przełącz wszystkie pakiety na packmana

szwagier

  • Geeko's friend
  • Maniak SUSE
  • *
  • Wiadomości: 2964
Odp: Błąd MPlayer/mpv po aktualizacji Leap 42.2 => 42.3
« Odpowiedź #2 dnia: Listopad 20, 2017, 03:44:18 pm »
Cytuj
Aktualizację przeprowadziłem offline z pendrajwa.
System działa poprawnie ale musiałem ponownie dodać repozytoria pacmana.
A wystarczyło zmienić numerki repozytoriów z 42.2 na 42.3 i zrobić aktualizację Yastem - tyle razy o tym pisano. Ale kto by to czytał.  ;)

klatu

  • Początkujący
  • *
  • Wiadomości: 11
Odp: Błąd MPlayer/mpv po aktualizacji Leap 42.2 => 42.3
« Odpowiedź #3 dnia: Listopad 20, 2017, 03:59:41 pm »
Miałem chwilę słabości. Przypadkiem miałem pena z nowym suse i tak wyszło. Już nie poradzę, mleko się rozlało.

Już mieniałem repozytoria na pacmana, zapomniałem napisać.
Przy okazji: dojście do tej opcji w YAST2 to jakieś nieporozumienie.

szwagier

  • Geeko's friend
  • Maniak SUSE
  • *
  • Wiadomości: 2964
Odp: Błąd MPlayer/mpv po aktualizacji Leap 42.2 => 42.3
« Odpowiedź #4 dnia: Listopad 20, 2017, 04:48:02 pm »
Cytuj
Już mieniałem repozytoria na pacmana, zapomniałem napisać.
Nie wiem czy myślimy o tym samym. Chodzi o przełączenie pakietów systemowych w repo Packmana.
Wcześniej zaptaszkuj zgodę na zmianę dostawcy.
« Ostatnia zmiana: Listopad 20, 2017, 04:50:22 pm wysłana przez szwagier »

klatu

  • Początkujący
  • *
  • Wiadomości: 11
Odp: Błąd MPlayer/mpv po aktualizacji Leap 42.2 => 42.3
« Odpowiedź #5 dnia: Listopad 20, 2017, 05:02:23 pm »
Potwierdzam, zamieniałem repozytoria systemowe na packmana, ale żadnej zgody do odfajkowania tam nie widzę.

szwagier

  • Geeko's friend
  • Maniak SUSE
  • *
  • Wiadomości: 2964
Odp: Błąd MPlayer/mpv po aktualizacji Leap 42.2 => 42.3
« Odpowiedź #6 dnia: Listopad 20, 2017, 05:17:10 pm »
Cytuj
ale żadnej zgody do odfajkowania tam nie widzę
Menu główne  > Opcje.
Pokaż swoje repozytoria, może tam masz coś namieszane, czyli wynik z:
zypper lr -d
Cytuj
Potwierdzam, zamieniałem repozytoria systemowe na packmana
Nie repozytoria, tylko pakiety w repozytorium packmana.
« Ostatnia zmiana: Listopad 20, 2017, 05:25:05 pm wysłana przez szwagier »

klatu

  • Początkujący
  • *
  • Wiadomości: 11
Odp: Błąd MPlayer/mpv po aktualizacji Leap 42.2 => 42.3
« Odpowiedź #7 dnia: Listopad 20, 2017, 05:24:14 pm »
No nie była zaznaczona zgoda. Zaznaczenie nic nie dało.

krab@linux-aiou:~> zypper lr -d
Priorytety repozytoriów nie mają zastosowania. Wszystkie włączone repozytoria współdzielą ten sam priorytet.

#  | Alias                     | Nazwa                                   | Włączono | Sprawdzaj GPG | Odśwież | Priorytet | Typ    | Adres URI                                                                | Usługa
---+---------------------------+-----------------------------------------+----------+---------------+---------+-----------+--------+--------------------------------------------------------------------------+-------
 1 | dvd                       | dvd                                     | Tak      | (r ) Tak      | Tak     |   99      | rpm-md | http://opensuse-guide.org/repo/openSUSE_Leap_42.3/                       |       
 2 | openSUSE-Leap-42.3-0      | openSUSE-Leap-42.3-0                    | Nie      | ----          | ----    |   99      | yast2  | hd:///?device=/dev/disk/by-id/usb-Wilk__0708562D12944E57-0:0-part2       |       
 3 | packman                   | packman                                 | Tak      | (r ) Tak      | Tak     |   99      | rpm-md | http://packman.inode.at/suse/openSUSE_Leap_42.3/                         |       
 4 | packman.inode.at-suse     | Packman Repository                      | Tak      | (r ) Tak      | Tak     |   99      | rpm-md | http://packman.inode.at/suse/openSUSE_Leap_42.3/                         |       
 5 | repo-debug                | openSUSE-Leap-42.3-Debug                | Nie      | ----          | ----    |   99      | NONE   | http://download.opensuse.org/debug/distribution/leap/42.3/repo/oss/      |       
 6 | repo-debug-non-oss        | openSUSE-Leap-42.3-Debug-Non-Oss        | Nie      | ----          | ----    |   99      | NONE   | http://download.opensuse.org/debug/distribution/leap/42.3/repo/non-oss/  |       
 7 | repo-debug-update         | openSUSE-Leap-42.3-Update-Debug         | Nie      | ----          | ----    |   99      | NONE   | http://download.opensuse.org/debug/update/leap/42.3/oss/                 |       
 8 | repo-debug-update-non-oss | openSUSE-Leap-42.3-Update-Debug-Non-Oss | Nie      | ----          | ----    |   99      | NONE   | http://download.opensuse.org/debug/update/leap/42.3/non-oss/             |       
 9 | repo-non-oss              | openSUSE-Leap-42.3-Non-Oss              | Tak      | (r ) Tak      | Tak     |   99      | yast2  | http://download.opensuse.org/distribution/leap/42.3/repo/non-oss/        |       
10 | repo-oss                  | openSUSE-Leap-42.3-Oss                  | Tak      | (r ) Tak      | Tak     |   99      | yast2  | http://download.opensuse.org/distribution/leap/42.3/repo/oss/            |       
11 | repo-source               | openSUSE-Leap-42.3-Source               | Nie      | ----          | ----    |   99      | NONE   | http://download.opensuse.org/source/distribution/leap/42.3/repo/oss/     |       
12 | repo-source-non-oss       | openSUSE-Leap-42.3-Source-Non-Oss       | Nie      | ----          | ----    |   99      | NONE   | http://download.opensuse.org/source/distribution/leap/42.3/repo/non-oss/ |       
13 | repo-update               | openSUSE-Leap-42.3-Update               | Tak      | (r ) Tak      | Tak     |   99      | rpm-md | http://download.opensuse.org/update/leap/42.3/oss/                       |       
14 | repo-update-non-oss       | openSUSE-Leap-42.3-Update-Non-Oss       | Tak      | (r ) Tak      | Tak     |   99      | rpm-md | http://download.opensuse.org/update/leap/42.3/non-oss/                   |       
krab@linux-aiou:~>

szwagier

  • Geeko's friend
  • Maniak SUSE
  • *
  • Wiadomości: 2964
Odp: Błąd MPlayer/mpv po aktualizacji Leap 42.2 => 42.3
« Odpowiedź #8 dnia: Listopad 20, 2017, 05:36:05 pm »
Uporządkuj sobie repozytoria bo masz podwojone.
Jak zrobisz porządek, otwórz konsolę i:
su
zypper ref
a potem
zypper dup
żeby system zrobił porządek z pakietami. Zawsze zgadzaj się na zmianę dostawcy.
A jeszcze na wszelki wypadek:
zypper install ffmpeg lame gstreamer-plugins-bad gstreamer-plugins-ugly gstreamer-plugins-ugly-orig-addon gstreamer-plugins-libav libdvdcss2

Tak przełączasz pakiety?
« Ostatnia zmiana: Listopad 20, 2017, 05:47:21 pm wysłana przez szwagier »

klatu

  • Początkujący
  • *
  • Wiadomości: 11
Odp: Błąd MPlayer/mpv po aktualizacji Leap 42.2 => 42.3
« Odpowiedź #9 dnia: Listopad 20, 2017, 05:59:13 pm »
Jeden pakiet przywrócił do wersji z repo openSUSE, tamten pakiet kodeków mam więc nie miał nic do roboty. Zresztą multimedia mi działają tylko ten SMPlayer nie chce :/

ikey

  • SUSE Guru
  • ****
  • Wiadomości: 874
Odp: Błąd MPlayer/mpv po aktualizacji Leap 42.2 => 42.3
« Odpowiedź #10 dnia: Listopad 21, 2017, 01:55:19 pm »
Co masz w opcjach smplayera ustawione (w ogólnych) jako silnik?
Zobacz w zakładce wideo co masz ustawione jako sterownik wyjściowy.

Lenovo Think Pad Yoga 14. openSUSE Leap 42.3

klatu

  • Początkujący
  • *
  • Wiadomości: 11
Odp: Błąd MPlayer/mpv po aktualizacji Leap 42.2 => 42.3
« Odpowiedź #11 dnia: Listopad 21, 2017, 03:05:14 pm »
Silnik mam ustawiony 'Inny' i ścieżkę '/usr/bin/mpv'
Sterownik ustawiony na domyślny (ja tych ustawień nie ruszałem).

Po doinstalowaniu MPlayer i wybraniu go jako silnik zaczął odtwarzać :)
Zapytał tylko o wersję MPlayera, że nie może rozpoznać.
Dla mnie to dziwne, bo odtwarzacz mpv działa.

szwagier

  • Geeko's friend
  • Maniak SUSE
  • *
  • Wiadomości: 2964
Odp: Błąd MPlayer/mpv po aktualizacji Leap 42.2 => 42.3
« Odpowiedź #12 dnia: Listopad 21, 2017, 04:50:16 pm »
Cytuj
Po doinstalowaniu MPlayer i wybraniu go jako silnik zaczął odtwarzać :)
Zapytał tylko o wersję MPlayera, że nie może rozpoznać.
Dla mnie to dziwne, bo odtwarzacz mpv działa.
Dziwne jest twoje zdziwienie - przecież SMplayer to tylko nakładka na MPlayer.  ;)
Mnie dziwi to że Yast nie pobrał zależności.  :(
Niestety Yast w 42.3 jest mocno skopany. W 42.1 wszystko było OK, a potem to już coraz gorzej.

klatu

  • Początkujący
  • *
  • Wiadomości: 11
Odp: Błąd MPlayer/mpv po aktualizacji Leap 42.2 => 42.3
« Odpowiedź #13 dnia: Listopad 21, 2017, 06:45:39 pm »
No nie wiem, nie znam się, ale zypperem też już próbowałem.
A jak tak się sprawy mają to przemyślę i chyba cofnę się na ten 42.1.
Na tę chwilę jak dla mnie problem rozwiązany, bo mogę zpowrotem oglądać filmidła :D
Wszystkim dzięki wielkie za pomoc.
Pozdrawiam.