Autor Wątek: [Rozwiązane] Nvidia: Podmieniłem kartę graficzną  (Przeczytany 2868 razy)

0 użytkowników i 1 Gość przegląda ten wątek.

neozorro

  • SUSE User
  • *
  • Wiadomości: 62
[Rozwiązane] Nvidia: Podmieniłem kartę graficzną
« dnia: Wrzesień 17, 2017, 07:48:15 pm »
Pytanie tylko, po co to robić - ja w ciągu tygodnia od aktualizacji doświadczam freezów ekranu. Raz obraz zmienił mi się w jakieś krzaki i pomógł tylko hard reset...
Na karcie AMD nie miałem nigdy niespodzianek, ale ostatnio mi padła i zmieniłem na NVidie.
Teraz po aktualizacji mam taki efekt, że zniekształca mi napisy pod ikonami. Widok na poniższym zdjęciu.
Czy ktoś ma jakiś pomysł czy jest możliwość to naprawić?
Czy pozostaje tylko nowa instalacja?



Na górze fragment pulpitu przed wstrzymaniem.
Na dole po wstrzymaniu.
« Ostatnia zmiana: Wrzesień 27, 2017, 11:32:41 am wysłana przez neozorro »
magnetoit.pl

gryzon96

  • SUSE Power User
  • **
  • Wiadomości: 184
Odp: Nvidia: Podmieniłem kartę graficzną
« Odpowiedź #1 dnia: Wrzesień 18, 2017, 06:05:03 pm »
Jakie sterowniki- otwarte czy zamknięte?

neozorro

  • SUSE User
  • *
  • Wiadomości: 62
Odp: Nvidia: Podmieniłem kartę graficzną
« Odpowiedź #2 dnia: Wrzesień 19, 2017, 07:22:41 am »
Sterowniki są z repo nVidii
linux-p3kk:/home/jacek # hwinfo --gfxcard
27: PCI 100.0: 0300 VGA compatible controller (VGA)             
  [Created at pci.378]
  Unique ID: VCu0.Edstdr1drJ7
  Parent ID: vSkL.A7VT_UZ8ue0
  SysFS ID: /devices/pci0000:00/0000:00:01.0/0000:01:00.0
  SysFS BusID: 0000:01:00.0
  Hardware Class: graphics card
  Model: "nVidia GeForce 8600 GT"
  Vendor: pci 0x10de "nVidia Corporation"
  Device: pci 0x0402 "GeForce 8600 GT"
  SubVendor: pci 0x1458 "Gigabyte Technology Co., Ltd"
  SubDevice: pci 0x3452
  Revision: 0xa1
  Driver: "nvidia"
  Driver Modules: "nvidia"
  Memory Range: 0xf8000000-0xf8ffffff (rw,non-prefetchable)
  Memory Range: 0xe0000000-0xefffffff (ro,non-prefetchable)
  Memory Range: 0xf6000000-0xf7ffffff (rw,non-prefetchable)
  I/O Ports: 0xbf00-0xbf7f (rw)
  Memory Range: 0xf9000000-0xf901ffff (ro,non-prefetchable,disabled)
  IRQ: 27 (26378 events)
  I/O Ports: 0x3c0-0x3df (rw)
  Module Alias: "pci:v000010DEd00000402sv00001458sd00003452bc03sc00i00"
  Driver Info #0:
    XFree86 v4 Server Module: nv
  Config Status: cfg=no, avail=yes, need=no, active=unknown
  Attached to: #9 (PCI bridge)

Primary display adapter: #27
magnetoit.pl

gryzon96

  • SUSE Power User
  • **
  • Wiadomości: 184

szwagier

  • Geeko's friend
  • Maniak SUSE
  • *
  • Wiadomości: 2953
Odp: Nvidia: Podmieniłem kartę graficzną
« Odpowiedź #4 dnia: Wrzesień 22, 2017, 07:20:24 am »
Cytuj
Sterowniki są z repo nVidii
Na pewno są prawidłowo zainstalowane? Zobacz co pisze u mnie na dole - status sterownika.
linux-5meg:/home/susek # hwinfo --gfxcard
23: PCI 100.0: 0300 VGA compatible controller (VGA)             
  [Created at pci.378]
  Unique ID: VCu0.PLxlBw1DgxD
  Parent ID: vSkL.pCz0kNFNqf6
  SysFS ID: /devices/pci0000:00/0000:00:01.0/0000:01:00.0
  SysFS BusID: 0000:01:00.0
  Hardware Class: graphics card
  Model: "nVidia GP106 [GeForce GTX 1060 3GB]"
  Vendor: pci 0x10de "nVidia Corporation"
  Device: pci 0x1c02 "GP106 [GeForce GTX 1060 3GB]"
  SubVendor: pci 0x3842 "eVga.com. Corp."
  SubDevice: pci 0x6162
  Revision: 0xa1
  Driver: "nvidia"
  Driver Modules: "nvidia"
  Memory Range: 0xf6000000-0xf6ffffff (rw,non-prefetchable)
  Memory Range: 0xe0000000-0xefffffff (ro,non-prefetchable)
  Memory Range: 0xf0000000-0xf1ffffff (ro,non-prefetchable)
  I/O Ports: 0xe000-0xefff (rw)
  Memory Range: 0xf7000000-0xf707ffff (ro,non-prefetchable,disabled)
  IRQ: 32 (24546 events)                                                   
  I/O Ports: 0x3c0-0x3df (rw)                                                   
  Module Alias: "pci:v000010DEd00001C02sv00003842sd00006162bc03sc00i00"           
  Driver Info #0:                                                                     
    Driver Status: nouveau is not active                                               
    Driver Activation Cmd: "modprobe nouveau"                                             
  Driver Info #1:
    Driver Status: nvidia_drm is active
    Driver Activation Cmd: "modprobe nvidia_drm"
  Driver Info #2:
    Driver Status: nvidia is active
    Driver Activation Cmd: "modprobe nvidia"
  Config Status: cfg=no, avail=yes, need=no, active=unknown
  Attached to: #8 (PCI bridge)


neozorro

  • SUSE User
  • *
  • Wiadomości: 62
Odp: Nvidia: Podmieniłem kartę graficzną
« Odpowiedź #5 dnia: Wrzesień 22, 2017, 09:06:31 am »
Spróbowałbym z tym
W katalogu /etc/X11/xorg.conf.d nie ma pliku 20-nvidia.conf


Na pewno są prawidłowo zainstalowane? Zobacz co pisze u mnie na dole - status sterownika.
linux-5meg:/home/susek # hwinfo --gfxcard
     
  Driver Info #0:                                                                     
    Driver Status: nouveau is not active                                               
    Driver Activation Cmd: "modprobe nouveau"                                             
  Driver Info #1:
    Driver Status: nvidia_drm is active
    Driver Activation Cmd: "modprobe nvidia_drm"
  Driver Info #2:
    Driver Status: nvidia is active
    Driver Activation Cmd: "modprobe nvidia"
  Config Status: cfg=no, avail=yes, need=no, active=unknown
  Attached to: #8 (PCI bridge)
Rzeczywiście nie ma u mnie tych wpisów.
Co proponujesz, aby w tej sytuacji zrobić?
magnetoit.pl

szwagier

  • Geeko's friend
  • Maniak SUSE
  • *
  • Wiadomości: 2953
Odp: Nvidia: Podmieniłem kartę graficzną
« Odpowiedź #6 dnia: Wrzesień 22, 2017, 09:37:12 am »
Przeinstaluj stery nvidii jeszcze raz.
Ale powiem szczerze Leap ze sterami nvidii to najbardziej niestabilny linux jakie testowałem. Nie wiesz kiedy ci się wyłoży do czarnego ekranu - właśnie zaliczyłem to dzisiaj a to już nie pierwszy raz.
Na nouveau da się pracować ale u mnie działa tragicznie, nawet nie rozpoznaje monitora. Najlepszy z Suse to był jednak 13.2 - tu wszystko działało.
I dlatego czasowo jestem na Mincie 18.3 z KDE - stabilność wzorcowa ze sterami nvidii i kernelem 4.13.

neozorro

  • SUSE User
  • *
  • Wiadomości: 62
Odp: Nvidia: Podmieniłem kartę graficzną
« Odpowiedź #7 dnia: Wrzesień 27, 2017, 11:29:17 am »
Pogrzebałem trochę w NVIDIA X Server Settings i zaskoczyło  :)
Dzięki za podpowiedzi.

P.S.
Niestety kilka razy wyświetliło się poprawnie, po czym problem powrócił.
Odinstalowałem sterowniki nvidia i zainstalowałem je ponownie.
Niestety nic się nie zmieniło.
Ostatnio była też aktualizacja sterowników nvidii, ale też nic to nie zmieniło.
Postanowiłem odinstalować sterowniki nvidii.
System uruchomił się w trybie tekstowym.
Ustawiłem Driver: "nouveau" w jednym z plików w katalogu /etc/X11/xorg.conf.d/
Wystartowały X.
Po kilkukrotnym teście ze wstrzymaniem systemu i ponownym uruchomieniu wszystko jest ok  :)
Trochę żałuję , że nie założyłem karty AMD. Z nimi nigdy nie miałem żadnych problemów.
« Ostatnia zmiana: Październik 06, 2017, 07:18:02 pm wysłana przez neozorro »
magnetoit.pl