Autor Wątek: Retro - skaner na LPT  (Przeczytany 502 razy)

0 użytkowników i 1 Gość przegląda ten wątek.

SKIPPER

  • Początkujący
  • *
  • Wiadomości: 12
Retro - skaner na LPT
« dnia: Lipiec 02, 2017, 10:45:49 am »
Witam,

Proszę o podpowiedź związaną z niespójnością obsługi wiekowego skanera.
Instalator YaST do skanera znajduje urządzenie i poprawnie je testuje, lecz inne programy go nie widzą.
Próbowałem poprawić plik konfiguracyjny umax_pp.conf poprzez dodanie wiersza:
device : /dev/parport0
lecz nic to nie pomogło.


Konfiguracja systemu:
OpenSUSE 12.3
Xfce
skaner UMAX Astra 2000P podłączony do gniazda LPT
programy obsługujące skaner: "Proste skanowanie", "LibreOffice Writer"

W załącznikach przekazuję objawy na zrzutach ekranów.


SKIPPER

  • Początkujący
  • *
  • Wiadomości: 12
Odp: Retro - skaner na LPT
« Odpowiedź #1 dnia: Lipiec 02, 2017, 01:43:34 pm »
Jest postęp.

Dłubiąc w internecie znalazłem informację, że backend "umax_pp" obsługujący port LPT powinien być uruchamiany przez użytkownika "root". To chyba jest przyczyna opisanych wcześniej objawów, gdzie backend jest widziany przez program konfiguracyjny YaST, natomiast frontend SimpleScan uruchamiany przez zwykłego użytkownika nie ma dostępu do procesu użytkownika "root".
Przelogowałem się na konto "root" i SimpleScan widzi skaner bez problemu. Wykonałem też poprawnie przykładowy skan.
Próbując otworzyć obraz ze skanera we Writerze już mi się nie udało, gdyż nie zobaczył on skanera. W tym momencie konfiguracja zaczęła mi się destabilizować.
Doczytałem też, że obejściem problemu wymagań "root"a jest uruchomienie usługi serwera skanowania na localhost.
Wybrałem konfigurację domyślną i dzięki temu zabiegowi zwykły użytkownik widzi już skaner jako usługę sieciową.
Jest jeszcze problem ze stabilnością tej konfiguracji.