Autor Wątek: Biblioteki  (Przeczytany 638 razy)

0 użytkowników i 1 Gość przegląda ten wątek.

122AA

  • SUSE Guru Apprentice
  • ***
  • Wiadomości: 277
Biblioteki
« dnia: Czerwiec 13, 2017, 09:07:05 am »
Witam,
skąd mogę doinstalować następujące biblioteki libc6:i386 libgcc1:i386 libstdc++5:i386
libstdc++6:i386 libncurses5:i386
SuSe Leap 42.1 64
Pozdrawiam
Dobry programista wiesza się razem ze swoim programem.  :)
SuSE 13.2 x64

szwagier

  • Geeko's friend
  • Maniak SUSE
  • *
  • Wiadomości: 2864
Odp: Biblioteki
« Odpowiedź #1 dnia: Czerwiec 13, 2017, 05:32:01 pm »
RPM resource ?

Sanchez

  • Operator #suse.pl
  • Moderator
  • SUSE Guru
  • *
  • Wiadomości: 573
      • #suse.pl
Odp: Biblioteki
« Odpowiedź #2 dnia: Czerwiec 14, 2017, 07:12:02 am »
Niestety 42.1 przestał być już utrzymywany. Możesz spróbować podpiąć się pod repozytoria 42.2 i zainstalować przynajmniej część z tych bibliotek - libc i libstdc++5 nie widziałem (libc pewnie nazywa się inaczejj, libstdc++5 jakoś nie ma i może bardziej chodzi o libstdc++48?).

Do czego w ogóle potrzebne takie biblioteki i skąd taki zapis (nie wygląda jak opis bibliotek do SuSE)?
xchat --url irc://irc.freenode.net/#suse.pl

122AA

  • SUSE Guru Apprentice
  • ***
  • Wiadomości: 277
Odp: Biblioteki
« Odpowiedź #3 dnia: Czerwiec 14, 2017, 09:57:00 am »
chodzi o zainstalowanie programu księgowego do lefthand .
Pomoc techniczna kazała zainstalować te biblioteki bo inaczej program się nie uruchamia:(
Podobno pod Debianem program działa :(
Dobry programista wiesza się razem ze swoim programem.  :)
SuSE 13.2 x64

szwagier

  • Geeko's friend
  • Maniak SUSE
  • *
  • Wiadomości: 2864
Odp: Biblioteki
« Odpowiedź #4 dnia: Czerwiec 14, 2017, 02:33:17 pm »
Jak spojrzysz do RPM resource to zobaczysz że biblioteki te zakończyły swój żywot na wersji 13 Suska.
Nie za bardzo wierzę że je zainstalujesz do kapryśnego Leapa.
Chyba że pobierzesz deby i przekonwertujesz alienem do rpm - ale czy to zadziała to nie wiem.
Debianowate prowadzą inną politykę i np. najnowszy Mint ma wszystkie te biblioteki zainstalowane domyślnie.
A programy Lefthanda instalują się z palca.  ;)

122AA

  • SUSE Guru Apprentice
  • ***
  • Wiadomości: 277
Odp: Biblioteki
« Odpowiedź #5 dnia: Czerwiec 14, 2017, 09:23:03 pm »
Jak spojrzysz do RPM resource to zobaczysz że biblioteki te zakończyły swój żywot na wersji 13 Suska.
Nie za bardzo wierzę że je zainstalujesz do kapryśnego Leapa.
Chyba że pobierzesz deby i przekonwertujesz alienem do rpm - ale czy to zadziała to nie wiem.
Debianowate prowadzą inną politykę i np. najnowszy Mint ma wszystkie te biblioteki zainstalowane domyślnie.
A programy Lefthanda instalują się z palca.  ;)
No tak:( znaczy że co że mam rzucić wszystko i zainstalować Mint ?
Zainstalowałem sobie Leap 42.2 i teraz adobe air przestał działac:( a muszę mieć ten program zeby wysyłać deklaracje do us
nać:(!!!!!
a było tak dobrze miałem se SuSE-ła wer 13 ale się skończyła:( i teraz nic nie działa
Dobry programista wiesza się razem ze swoim programem.  :)
SuSE 13.2 x64

122AA

  • SUSE Guru Apprentice
  • ***
  • Wiadomości: 277
Odp: Biblioteki
« Odpowiedź #6 dnia: Czerwiec 14, 2017, 09:31:40 pm »
brak AdobeAIR przy instalacji wyskakuje mi to:(
(setup:12628): Gtk-WARNING **: Nie można odnaleźć modułu obsługującego motyw w module_path: "clearlooks",
i dalej kocha:( nie mogę zainstalować e-deklaracji
Mozę ktoś wie jak to przeskoczyć?

Dobry programista wiesza się razem ze swoim programem.  :)
SuSE 13.2 x64

szwagier

  • Geeko's friend
  • Maniak SUSE
  • *
  • Wiadomości: 2864
Odp: Biblioteki
« Odpowiedź #7 dnia: Czerwiec 15, 2017, 08:46:47 am »
5 minut roboty.  ;)

Sanchez

  • Operator #suse.pl
  • Moderator
  • SUSE Guru
  • *
  • Wiadomości: 573
      • #suse.pl
Odp: Biblioteki
« Odpowiedź #8 dnia: Czerwiec 16, 2017, 08:50:00 am »
122AA, próbowałeś zainstalować program księgowy na 42.1? Wyrzuca jakieś błędy? Może da się ten program uruchomić na nowszych wersjach bibliotek?
xchat --url irc://irc.freenode.net/#suse.pl