Autor Wątek: [KDE] [leap 42.2] nie działa k9copy  (Przeczytany 1105 razy)

0 użytkowników i 1 Gość przegląda ten wątek.

provayder

  • SUSE Power User
  • **
  • Wiadomości: 140
[leap 42.2] nie działa k9copy
« dnia: Listopad 22, 2016, 11:11:47 am »
Witam

Mam problem z programem k9copy. W zasadzie po przejściu na Leap 42.1 program nie działał i teraz po aktualizacji do 42.2 w dalszym ciągu nie działa. Uruchomienie przez ikonę powoduje pojawienie się na pasku okienka na ok. 1s. Jak odpalę konsolę i z linii wywołam k9copy to program się odpala, można wczytać obraz iso, wybrać co się chce skopiować i po wciśnięciu copy pojawia się komunikat, że obraz został utworzony (tak było w 42.1) lub że się pojawił jakiś błąd (tak jest w 42.2). Poniżej zrzut z okna konsoli:

maciej@linux-pi7b:~> k9copy
" /usr/bin/dvdauthor -x /home/maciej/k9ayH1934.xml"
QFSFileEngine::open: No file name specified
" /usr/bin/genisoimage -gui -v -graft-points -volid THE_5TH_WAVE -appid k9copy -volset-size 1 -volset-seqno 1 -no-cache-inodes -udf -iso-level 1 -dvd-video -o /home/maciej/THE_5TH_WAVE.iso /home/maciej/THE_5TH_WAVE"
Continue Clicked
1048576
Naruszenie ochrony pamięci (zrzut pamięci)
maciej@linux-pi7b:~>

Wszystkie zależności przy instalacji były OK, wszystkie wymagane programiki (mencoder, mplayer, dvdauthor, k3b, genisoimage) są zainstalowane. Pomoże ktoś?


pozdrawiam
provayder
« Ostatnia zmiana: Luty 20, 2017, 06:52:38 pm wysłana przez Stefan »
provayder
Zielony Użytkownik Linuksa
Lenovo G580 Intel i3-3110MTM Dual-Core CPU 4GB DDR3 GeForce GT710M openSuSE Leap 42.2 4.4.36-5-default x86_64 KDE5.26.0

marcinz

  • Global Moderator
  • SUSE Guru
  • *
  • Wiadomości: 676
  • No kabooom no! OpenSuse 12.2
Odp: [leap 42.2] nie działa k9copy
« Odpowiedź #1 dnia: Listopad 22, 2016, 02:08:47 pm »
Jak będę mieć chwilę to jutro zainstaluje i sprawdzę czy u mnie działa i dam znać jak sprawa wygląda.
Lapek: ASUS K50IJ-SX151 Wind XP|OpenSUSE 12.2 x86_64 KDE:  4.8.4, Kernel: 3.4.6-2.10-desktop
Stacjonarny: P IV 2.8 GHz z OpenSUSE 12.1

CameronPoe

  • SUSE Root
  • *****
  • Wiadomości: 1064
Odp: [leap 42.2] nie działa k9copy
« Odpowiedź #2 dnia: Grudzień 03, 2016, 12:50:37 am »
U mnie program k9copy działa na openSUSE 42.2 :thumleft:

Włączam konsolę -> odpalam k9copy i program się włącza -> przy włożonej płycie przyciskam Otwórz, aby załadować płytę do programu -> wybieram dokąd chcę zapisać i przyciskam Copy -> no i w konsoli zaczynają wyskakiwać poprawne wyniki:
cameron@linux-poe:~> k9copy
Continue Clicked
1048576

libdvdread: Attempting to retrieve all CSS keys
libdvdread: This can take a _long_ time, please be patient

libdvdread: Get key for /VIDEO_TS/VIDEO_TS.VOB at 0x00000143
libdvdread: Elapsed time 3
libdvdread: Get key for /VIDEO_TS/VTS_01_0.VOB at 0x00008fd6
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_01_1.VOB at 0x00012b24
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_02_0.VOB at 0x002d6a1f
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_02_1.VOB at 0x002d6a25
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_03_0.VOB at 0x002d6cf6
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_03_1.VOB at 0x002d6cfb
libdvdread: Elapsed time 1
libdvdread: Get key for /VIDEO_TS/VTS_04_0.VOB at 0x003d3d01
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_04_1.VOB at 0x003d3d06
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_05_0.VOB at 0x003d4c44
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_05_1.VOB at 0x003d4c49
libdvdread: Elapsed time 0
libdvdread: Found 5 VTS's
libdvdread: Elapsed time 4
" mkisofs -o /home/cameron/ENEMY_OF_THE_STATE.iso -dvd-video -udf -r -V ENEMY_OF_THE_STATE /tmp/k9copy/ENEMY_OF_THE_STATE"
QFSFileEngine::open: No file name specified
Błędna instrukcja (zrzut pamięci)
cameron@linux-poe:~>

Z twoich wyników wynika zapewne to, że coś grzebałeś w ustawieniach programu, więc w razie czego to usuń pliki z ustawieniami i zacznij od nowa.

To co pisałeś, że wyskakuje "obraz został utworzony" to zapewne chodzi o to, że musisz zaznaczać całe grupy tytułów do skopiowania, a nie tylko pojedyncze tytuły (pliki). Pamiętaj także, iż program tworzy katalog tymczasowy (domyślnie /tmp/k9copy), więc go po prostu usuń lub przypisz inny katalog tymczasowy, jeżeli wyskakuje, że "taki katalog już istnieje" :thumright:

Możliwe także, że masz wgrane złe pakiety lub czegoś brak, więc podaj wynik polecenia:
zypper se -si k9copy dvd mpeg2 xine2 vamps

szwagier

  • Geeko's friend
  • Maniak SUSE
  • *
  • Wiadomości: 2864
Odp: [leap 42.2] nie działa k9copy
« Odpowiedź #3 dnia: Grudzień 03, 2016, 07:29:32 am »
Cytuj
Uruchomienie przez ikonę powoduje pojawienie się na pasku okienka na ok. 1s.
Niewłaściwe przełączniki w linii poleceń programu. Wyedytuj program, wywal przełączniki i k9copy uruchamia się z ikony.
Bez żadnych problemów skopiowałem DVD do folderu.
« Ostatnia zmiana: Grudzień 03, 2016, 07:44:45 am wysłana przez szwagier »

provayder

  • SUSE Power User
  • **
  • Wiadomości: 140
Odp: [leap 42.2] nie działa k9copy
« Odpowiedź #4 dnia: Grudzień 08, 2016, 05:21:21 pm »
Dzięki za odpowiedzi. Udało mi się prawie wszystko ogarnąć i teraz program uruchamia się normalnie. Faktycznie okazało się, że w linii poleceń programu były niewłaściwe przełączniki k9copy -caption "%c %i %u". Po usunięciu i wpisaniu tylko k9copy program zaczął się uruchamiać przez ikonkę. Problem z brakiem przetwarzania filmu okazał się związany z opcją "use dvdAuthor for copy without menus". Niestety nadal coś jest nie tak z tworzeniem obrazu. Po otworzeniu filmu, zaznaczeniu co się ma kopiować, wszystko idzie do momentu wykonania nowego obrazu płyty. Program po prostu się zamyka.

EDIT1:
Po uruchomieniu k9copy z konsoli wygląda to tak:
maciej@linux-pi7b:~> k9copy
Continue Clicked
1048576

libdvdread: Attempting to retrieve all CSS keys
libdvdread: This can take a _long_ time, please be patient

libdvdread: Get key for /VIDEO_TS/VIDEO_TS.VOB at 0x00000142
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_01_0.VOB at 0x000009cf
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_01_1.VOB at 0x0000bf5c
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_02_1.VOB at 0x0030a9d9
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_03_1.VOB at 0x0030c6e3
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_04_1.VOB at 0x00372835
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_05_1.VOB at 0x0037f3b6
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_06_1.VOB at 0x0037f425
libdvdread: Elapsed time 0
libdvdread: Found 6 VTS's
libdvdread: Elapsed time 0
Naruszenie ochrony pamięci (zrzut pamięci)
maciej@linux-pi7b:~>

EDIT2:
Chyba doszedłem co jest nie tak z k9copy. Prawdopodobnie problemem jest dvdAuthor, bo: jak próbuję przerobić płytę pomijając menu i wszystkie inne dodatki to przy zaznaczonej opcji "use dvdAuthor for copy without menus" k9copy wogólenie podejmuje próby konwersji DVD9 do 4.4GB i pojawia się błąd. Po odznaczeniu tej opcji konwersja jest wykonywana, ale brakuje jakiejś finalizacji (na okienku z podglądem to jest etap, gdzie następuje uaktualnienie plików VOB). Tego nie ma a program się zamyka, bo jest "Naruszenie ochrony pamięci". Jak zaznaczę, żeby oryginalne menu zostało to wszystko idzie prawidłowo (przy zaznaczonej opcji "use dvdAuthor for copy without menus", i sądzę, że odznaczenie jej nic tu nie zmieni).

Jeszcze jedną dziwną rzecz zauważyłem, w końcu postanowiłem odinstalować k9copy, usunąłem pliki konfiguracyjne, usunąłem wpisy z menu Multimedia, zrobiłem restart kompa i ponownie zainstalowałem k9copy. No i ani w menu Multimedia nie pojawiły się wpisy do uruchomienia, ani nie pokazało się dodatkowe menu z nowo zainstalowanymi programami. Czemu tak się stało? ja na razie nie wiem.
« Ostatnia zmiana: Grudzień 09, 2016, 02:10:53 pm wysłana przez provayder »
provayder
Zielony Użytkownik Linuksa
Lenovo G580 Intel i3-3110MTM Dual-Core CPU 4GB DDR3 GeForce GT710M openSuSE Leap 42.2 4.4.36-5-default x86_64 KDE5.26.0