Autor Wątek: Firefox - spolszczenie & flashplayer  (Przeczytany 929 razy)

0 użytkowników i 1 Gość przegląda ten wątek.

marbedo

  • Początkujący
  • *
  • Wiadomości: 2
Firefox - spolszczenie & flashplayer
« dnia: Czerwiec 27, 2016, 07:54:58 am »
System: openSUSE Leap 42.1
Firefox: 47.0

Na firefoxie z repozytoriów w żaden sposób nie jestem z stanie zmienić języka na PL. Próbowałem już wszystkiego, usuwanie wszystkich języków oprócz PL, wgrywanie nowej paczki języków, zmiana about:config itp. Na szczęście adobe flashplayer działa.

Ściągnąłem wersję firefox.tar.bz2 i tutaj język działa, ale znów flashplayer nie. Nie wiem jak wgrać firefoxa tak aby jak z repozytoriów dodawł się do systemu i może wtedy flashplayer by zadziałał. Dodatkowo w tej wersji jest trochę zabawy jak np podmiana oryginalnej ikonki do skrótu na pulpit. Tak więc wolałbym aby ff z repozytoriów udało się przerobić na PL.

Ciekawostka, przed chwilą zainstalowałem system na VM i domyślnie jest FF w języku polskim. Może to zależeć od instalacji?

Z góry dziękuje za pomoc.

« Ostatnia zmiana: Czerwiec 27, 2016, 08:08:39 am wysłana przez marbedo »

gryzon96

  • SUSE Power User
  • **
  • Wiadomości: 147
Odp: Firefox - spolszczenie & flashplayer
« Odpowiedź #1 dnia: Czerwiec 27, 2016, 06:14:13 pm »
Próbowałeś instalacji na czystym profilu?

marbedo

  • Początkujący
  • *
  • Wiadomości: 2
Odp: Firefox - spolszczenie & flashplayer
« Odpowiedź #2 dnia: Czerwiec 28, 2016, 05:44:31 am »
Sprawa rozwiązana. Problem tkwił w rodzaju instalacji. Jeśli instalowałem z UEFI to niestety same problemy od właśnie zmiany języka w FF jak i np problemy z aktualizacją systemu, aplikacji itp. Po instalacji bez UEFI wszystko śmiga (prawie bo mam problem ze skanerem).

Premislaus

  • SUSE User
  • *
  • Wiadomości: 53
Odp: Firefox - spolszczenie & flashplayer
« Odpowiedź #3 dnia: Czerwiec 29, 2016, 04:59:52 am »
Sprawa rozwiązana. Problem tkwił w rodzaju instalacji. Jeśli instalowałem z UEFI to niestety same problemy od właśnie zmiany języka w FF jak i np problemy z aktualizacją systemu, aplikacji itp. Po instalacji bez UEFI wszystko śmiga (prawie bo mam problem ze skanerem).

Mam Tumbleweed z KDE, zainstalowany w trybie UEFI. Instalowałem też Fedorę 24 (Gnome 3) i Ubuntu 16.04 (Unity). Na openSUSE co prawda system jest po polsku (można zauważyć jakieś braki w tłumaczeniu) i FF też się włącza po polsku, ale wiele stron odpala się w angielskiej wersji językowej. Dobrze to widać na Gmailu, albo YouTube. Okienko z logowaniem na Gmailu jest po angielsku i język dopiero zmienia się po zalogowaniu. YouTube włącza się domyślnie po angielsku. Odwrotna sytuacja jest na Chrome.

Na Fedorze i Ubuntu, też zainstalowanych w trybie UEFI, nie ma żadnego problemu. Podejrzewam, że coś jest nie tak z paczką w openSUSE, bądź z jakimiś konfiguracjami w KDE.

Inna rzecz, że w openSUSE sytuacja z instalowaniem programów z poza oficjalnych repozytoriów powinna się poprawić w niedługim czasie - https://www.reddit.com/r/openSUSE/comments/4puty7/richard_brown_distribute_or_die_arguing_against/. Kierownictwo jest świadome wielu problemów. U mnie np. 1-click Install proponuje dodawanie repozytoriów z "deleted" w adresach. Ostatnio na mailing liście Packmana i redditcie widziałem dyskusje, w której osoby z openSUSE starały się paczkującym z Packmana wyjaśnić, że nie powinno się dla Leap i Tumbleweed budować paczek w wersji devel, gdyż np. gstreamer chce się codziennie aktualizować, a nie ma tam żadnych zmian.

Leap może mieć problemy z UEFI. Na pewno instalator nie zadziała z włączonym Secure Boot, gdyż ma jakiś antyczny pakiet który zaplątał się podczas integracji kodus ze SLES z openSUSE. Wersja 13.2 instaluje się z Secure Boot. Niedawno na forum wrzucałem link do angielskiego forum gdzie to poruszono.

PS. Flash player u mnie działał, wczoraj, dzisiaj go usunąłem. Znalazłem instrukcję w sieci jak dodać repozytorium Adobe. Od kilku dni próbuję zmusić przeglądarki do akceleracji video... No ale żaden przeze mnie znaleziony sposób nie działa. Z tego co się zorientowałem, taka akceleracja póki co jest niemożliwa. Flash działa od kopa w Chrome.
« Ostatnia zmiana: Czerwiec 29, 2016, 05:02:30 am wysłana przez Premislaus »