Autor Wątek: problem z połączeniem z vsftpd  (Przeczytany 17926 razy)

0 użytkowników i 1 Gość przegląda ten wątek.

vonstefano

  • Początkujący
  • *
  • Wiadomości: 23
problem z połączeniem z vsftpd
« dnia: Styczeń 28, 2014, 10:58:27 am »
Witam!

zainstalowalem i skonfigurowalem vsftpd i jak sie proboje połączyć lokalnie to mnie nie łączy - zainstalowalem go przez zypper i usluga jest aktywna. Jak host podaje 10.0.0.1 (probowalem tez 127.0.0.1) i port 22 uzytnownik anonymous bez hasla. Probowalem filezilla - to wybieralo jakis domyslny server fsftp, a teraz próbuje przez krusader'a i tez bez powodzenia. Gdzie moze byc problem? Stawiam to na suse 13.1

Fisiu

  • Geeko's friend
  • Maniak SUSE
  • *
  • Wiadomości: 4632
      • la manzana
Odp: problem z połączeniem z vsftpd
« Odpowiedź #1 dnia: Styczeń 28, 2014, 11:48:26 am »
Czy usługa jest uruchomiona w ogóle? Jeśli będziesz łączył się z innego komputera, to jeszcze musisz otworzyć port w zaporze.

vonstefano

  • Początkujący
  • *
  • Wiadomości: 23
Odp: problem z połączeniem z vsftpd
« Odpowiedź #2 dnia: Styczeń 28, 2014, 02:30:34 pm »
Usługa jest aktywan, a loguje lokalnie i jak do tej pory bez powodzenia.

Fisiu

  • Geeko's friend
  • Maniak SUSE
  • *
  • Wiadomości: 4632
      • la manzana
Odp: problem z połączeniem z vsftpd
« Odpowiedź #3 dnia: Styczeń 28, 2014, 03:59:13 pm »
A skąd wiesz, że logowanie dla 'anonymous' jest aktywne na serwerze ftp? Albo konfiguracja serwera + dowód, że "nie da się lokalnie zalogować", albo nigdzie dalej nie zajdziemy.

vonstefano

  • Początkujący
  • *
  • Wiadomości: 23
Odp: problem z połączeniem z vsftpd
« Odpowiedź #4 dnia: Styczeń 28, 2014, 04:39:30 pm »
Ustawilem to tu:
#
# Allow anonymous FTP? (Beware - allowed by default if you comment this out).
anonymous_enable=YES
#
# The maximum data transfer rate permitted, in bytes per second, for anonymous
authenticated users. The default is 0 (unlimited).
#anon_max_rate=7200
#
# Anonymous users will only be allowed to download files which are
# world readable.
anon_world_readable_only=YES
#
# Default umask for anonymus users is 077. You may wish to change this to 022,
# if your users expect that (022 is used by most other ftpd's)
anon_umask=022

czy moze sie nie podlacza filezilla do servera - bo jak sie flacza to nie wyswietla vsftpd tylko  fzSftp started, w starszej wersji opensuse udalo sie bez problemu, a tu nic

rilicek

  • Geeko's friend
  • SUSE Root
  • *
  • Wiadomości: 2062
  • Kto nie ryzykuje, ten w kozie nie siedzi.
Odp: problem z połączeniem z vsftpd
« Odpowiedź #5 dnia: Styczeń 28, 2014, 05:47:15 pm »
@vonstefano
Jaki masz adres serwera, a z jakim próbujesz się połączyć?
Podaj ifconfig z serwera.
openSUSE Leap 42.2

vonstefano

  • Początkujący
  • *
  • Wiadomości: 23
Odp: problem z połączeniem z vsftpd
« Odpowiedź #6 dnia: Styczeń 28, 2014, 05:55:07 pm »
Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0

rilicek

  • Geeko's friend
  • SUSE Root
  • *
  • Wiadomości: 2062
  • Kto nie ryzykuje, ten w kozie nie siedzi.
Odp: problem z połączeniem z vsftpd
« Odpowiedź #7 dnia: Styczeń 28, 2014, 06:15:42 pm »
1. Używaj znacznika [code]tekst[/code]:
tekst2. Pokaż cały wynik polecenia.
openSUSE Leap 42.2

vonstefano

  • Początkujący
  • *
  • Wiadomości: 23
Odp: problem z połączeniem z vsftpd
« Odpowiedź #8 dnia: Styczeń 28, 2014, 06:23:41 pm »
ens33     Link encap:Ethernet  HWaddr 00:0C:29:94:A6:01 
          inet addr:192.168.204.128  Bcast:192.168.204.255  Mask:255.255.255.0
          inet6 addr: fe80::20c:29ff:fe94:a601/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:4046058 errors:3 dropped:3 overruns:0 frame:0
          TX packets:18168 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:292261329 (278.7 Mb)  TX bytes:1890385 (1.8 Mb)
          Interrupt:19 Base address:0x2000

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:326 errors:0 dropped:0 overruns:0 frame:0
          TX packets:326 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:16960 (16.5 Kb)  TX bytes:16960 (16.5 Kb)

Fisiu

  • Geeko's friend
  • Maniak SUSE
  • *
  • Wiadomości: 4632
      • la manzana
Odp: problem z połączeniem z vsftpd
« Odpowiedź #9 dnia: Styczeń 28, 2014, 06:31:49 pm »
Pokaż wynik `systemctl status vsftpd` oraz `ftp anonymous@localhost`.

vonstefano

  • Początkujący
  • *
  • Wiadomości: 23
Odp: problem z połączeniem z vsftpd
« Odpowiedź #10 dnia: Styczeń 28, 2014, 07:28:15 pm »
zrobilem wszystko od nowa łącznie z instalacja servera, przywróciłem nawet system z kopii i niestety teraz usługa sie nie włącza:
linux-pykw:~ # systemctl status vsftpd
vsftpd.service - Vsftpd ftp daemon
   Loaded: loaded (/usr/lib/systemd/system/vsftpd.service; disabled)
   Active: inactive (dead)
teraz to juz sam nie wiem, Wczesniej usunalem vsftpd, gdyz wgralem proftpd ale tez sie nie wlaczal. Ustawilem wszystko po przywrroceniu z kopii, jak wczesniej ale nie dziala. Teraz to juz nie wiem, co jest nie tak

vonstefano

  • Początkujący
  • *
  • Wiadomości: 23
Odp: problem z połączeniem z vsftpd
« Odpowiedź #11 dnia: Styczeń 28, 2014, 08:23:25 pm »
tak mam ustawiony plik vsftpd.conf
service ftp
{
        socket_type             = stream
        protocol                = tcp
        wait                    = no
        user                    = root
        server                  = /usr/sbin/vsftpd
#        server_args             =
#        log_on_success          += DURATION USERID
#        log_on_failure          += USERID
#        nice                    = 10
        disable                 = no
}[/
wczesniej mialem tak samo wszystko ustaione i dzialalo, to znaczy usluga sie uruchamiala, a teraz nie
w filezilli przy probie polaczenia wyswietla to:
Response: fzSftp started
Command: open "anonymous@127.0.0.1" 21
Error: Connection timed out
Error: Could not connect to server
Error: Could not connect to server
« Ostatnia zmiana: Styczeń 28, 2014, 08:56:59 pm wysłana przez vonstefano »

mastal

  • Moderator działu
  • SUSE Root
  • *
  • Wiadomości: 1926
Odp: problem z połączeniem z vsftpd
« Odpowiedź #12 dnia: Styczeń 28, 2014, 09:32:52 pm »
Zastanów się co robisz, bo z tego co piszesz wynika iż robisz sobie krzywdę i to ogromną. Mieszasz mechanizmy kontroli serwisu !!!!!

Aby jeszcze bardziej uzmysłowić sobie co kombinujesz uświadamiam iż instalacja i uruchomienie od zera ftp zajęła mi 60s. W tym czasie zdążyłem zainstalować pakiet, sprawdzić domyślną konfigurację, uruchomić usługę, sprawdzić że działa nasłuch na porcie 21 oraz podłączyć się anonimowo do ftp'a.
Nic nie musiałem edytować.

Dla ułatwienia - podpowiedź Fisia jest bardzo dobra - trzeba tylko włączyć myślenie.
1. Zapoznaj się ze stroną http://www.linux-tips-and-tricks.de/quickstart#English i wykonaj tam zawarte punkty
2. Przyślij wynik skryptu collectNWData.sh

vonstefano

  • Początkujący
  • *
  • Wiadomości: 23
Odp: problem z połączeniem z vsftpd
« Odpowiedź #13 dnia: Styczeń 28, 2014, 09:54:54 pm »
Dzieki za taka pomoc - podaruje sobie ta instalac - naprawde super porady...
...."jestem sper, zrobilem server w 60 sekund - zero krytycyzmu!!

rilicek

  • Geeko's friend
  • SUSE Root
  • *
  • Wiadomości: 2062
  • Kto nie ryzykuje, ten w kozie nie siedzi.
Odp: problem z połączeniem z vsftpd
« Odpowiedź #14 dnia: Styczeń 28, 2014, 10:04:43 pm »
@vonstefano
Ty się nie unoś, tylko pomyśl. Prawdopodobnie przed Twoimi kombinacjami miałeś uruchomiony serwer, tylko zły adres wpisywałeś.
Jakbyś napisał/narysował jak wygląda Twoje połączenie, gdzie i co wpisujesz + komendy podane przez Fisia, byłoby nam łatwiej.

Zastanawia mnie jendo, jak chciałeś się wbić naserwer FTP wpisująć
... 10.0.0.1 (probowalem tez 127.0.0.1) i port 22 ...
kiedy twój serwer ma IP:
...
          inet addr:192.168.204.128  ...
No i pytanie podstawowe, skąd Ci się wziął port 22?
openSUSE Leap 42.2