Autor Wątek: SLED 11 OEM ProBook 4540s  (Przeczytany 21162 razy)

0 użytkowników i 1 Gość przegląda ten wątek.

Fisiu

  • Geeko's friend
  • Maniak SUSE
  • *
  • Wiadomości: 4632
      • la manzana
Odp: SLED 11 OEM ProBook 4540s
« Odpowiedź #15 dnia: Kwiecień 03, 2013, 10:55:29 am »
Ale to jest repozytorium dla SLE 11 bez SP2. Wcześniej podlinkowałem prawidłowe repo.
Jakiego biblioteki i skąd próbowałeś zainstalować, że miałeś problemy z zależnościami?

Mecin

  • Początkujący
  • *
  • Wiadomości: 11
Odp: SLED 11 OEM ProBook 4540s
« Odpowiedź #16 dnia: Kwiecień 03, 2013, 11:24:02 am »
To repozytorium ma te same paczki plus jest ich trochę więcej - co mnie interesowało to vlc. Gdzieś na forum wyczytałem i dodałem, działa.

Do Pythona potrzebowałem załadować matplotlib, który wymagał numpy w wersji minimalnie 1.6 (albo 1.4 bo z głowy już piszę) a w systemie jest 1.3. Kolejno przyczepiał się do gcc itp. piekło jak na Slackware. Nie ma co nawet pisać. Dodam tylko że np w Debianie matplotlib idzie z repo z paczki i chyba nawet w Squeeze jest wersja numpy nowsza. Jak tak dalej będzie to się pogniewamy z SUSE.

Fisiu

  • Geeko's friend
  • Maniak SUSE
  • *
  • Wiadomości: 4632
      • la manzana
Odp: SLED 11 OEM ProBook 4540s
« Odpowiedź #17 dnia: Kwiecień 03, 2013, 03:26:53 pm »
Repo ma paczki te same, ale to dla SP2 zostało zbudowane w oparciu o pakiety dostępne w SP2, a te są różne niż w SLE11 bez jakiegokolwiek SP.

Poczytaj o repozytoriach i jak z nich korzystać. matplotlib jest dostępny w kilku repozytoriach, łącznie z wszystkimi zależnościami. Najnowsze wersje bibliotek pythona przygotowane dla SLE11 SP2 dostępne są w tym repo: http://download.opensuse.org/repositories/devel:/languages:/python/SLE_11_SP2/

Mecin

  • Początkujący
  • *
  • Wiadomości: 11
Odp: SLED 11 OEM ProBook 4540s
« Odpowiedź #18 dnia: Kwiecień 03, 2013, 07:26:17 pm »
Dziękuje bardzo, sam nie potrafię jakoś odnaleźć tych repozytoriów ... Że też nikt nie zrobił jakieś wiki czy chociaż krótkiej notki.
Mimo Twoich starań wciąż mam starego Pythona, niby matplotlib jest (pobiera się) ale to wciąż stara wersja. Obawiam się że tak będzie w przypadku wszystkich moich potrzeb bo dopiero zaczyna wychodzić w praniu - chociaż wolę nie krakać.
I tak wychodzi na to że SLE jest baardzo biedny. Można zaryzykować stwierdzenie że jest dostępne tylko to co widać. Na szczęście repozytoria społecznościowe trochę ratują mu skórę.

Edycja
python-numpy jest w tym repozytorium ale ma zepsutą zależność, po sforsowaniu instalacji skrypty głupieją całkowicie. Nie ma sensu w to brnąć dalej :D
« Ostatnia zmiana: Kwiecień 03, 2013, 07:38:03 pm wysłana przez Mecin »

Fisiu

  • Geeko's friend
  • Maniak SUSE
  • *
  • Wiadomości: 4632
      • la manzana
Odp: SLED 11 OEM ProBook 4540s
« Odpowiedź #19 dnia: Kwiecień 03, 2013, 09:14:07 pm »
Możliwe, że konieczna jest zmiana dostawców dla innych pakietów, ale bez komunikatów zyppera albo YaSTa - nic więcej nie możemy poradzić.

Mecin

  • Początkujący
  • *
  • Wiadomości: 11
Odp: SLED 11 OEM ProBook 4540s
« Odpowiedź #20 dnia: Kwiecień 04, 2013, 06:29:33 am »
Było tylko do wyboru pozostawienie starej wersji, lub zignorować zależność i instalować nową wersję. Zainstalowałem ale jak mówiłem nie działa i tak matplotlib, ogólnie ściana błędów - sprawa zamknięta bo już dawno na W8 co miałem do zrobienia to zrobiłem.
Dziś zrobię test drukarki - zobaczymy czy sobie poradzi z dość problematycznym sprzętem :-).

Edycja

Dziś od rana wałkuję sprawę pythona bo miałem chwilkę i udało mi się zmusić do współpracy pythona (domyślnego w SLE) + matplotlib, brakowało kilka zależności które musiałem (albo i nie?) dociągać z otchłani internetu potrzebnych do poprawnego działania numpy. Po prostu analizowałem konsekwentnie komunikaty po błędnym załadowaniu numpy.
« Ostatnia zmiana: Kwiecień 04, 2013, 03:42:00 pm wysłana przez Mecin »