Autor Wątek: World of Tanks  (Przeczytany 12482 razy)

0 użytkowników i 1 Gość przegląda ten wątek.

Pangenitor

  • Początkujący
  • *
  • Wiadomości: 10
Odp: World of Tanks
« Odpowiedź #15 dnia: Sierpień 13, 2015, 02:07:48 pm »
Instalacja dochodzi do momentu, gdy otwiera się okno przeglądarki i następuje uruchomienie "Aktualizacja gry rozpoczęcie pobierania torrent" w tym momencie zatrzymuje się na ok 7 sekundzie.
W oknie Playonlinux kręci się wskaźnik i jest komunikat "Instalacja World of Tanks w toku proszę czekać" i tak wszystko zostaje....

CameronPoe

  • SUSE Root
  • *****
  • Wiadomości: 1064
Odp: World of Tanks
« Odpowiedź #16 dnia: Sierpień 13, 2015, 02:33:25 pm »
No to już wszystko wiadomo.

Mianowicie jest problem z pobieraniem plików aktualizacyjnych torrent przez program aktualizacyjny gry, więc spróbuj kliknąć w górnym prawym rogu ikonkę "klucza francuskiego" i odznaczyć "Zezwól na korzystanie z protokołu torrent" i spróbuj ponownie, ale lepiej chyba będzie jak wejdziesz do podkatalogu "Updates" tam gdzie jest wgrana gra i pościągasz "ręcznie" wszystkie pliki *.torrent w programie Ktorrent (tym sposobem będziesz widział ile jeszcze zostało i jak długo będzie się to ściągać, a jest tego 10 plików aktualizacyjnych i zajmują one 5,6GB dla trybu SD, a dla HD chyba drugie tyle). Później przekopiuj te pliki właśnie do tego podkatalogu i wtedy gra już przejdzie dalej.

P.S. Nie zapomnij przed uruchomieniem gry dopisać w konfiguracji Wine dwie dodatkowe reguły w zakładce "Biblioteki" (bo inaczej nie wejdziesz do garażu):
msvcp110 (natywna, wbudowana)
msvcr110 (natywna, wbudowana)

Życzę powodzenia na polu walki!!! ...ale ostrzegam, że gra jest wciągająca i czasami wkur*iająca ;)
« Ostatnia zmiana: Sierpień 13, 2015, 02:35:02 pm wysłana przez CameronPoe »

Pangenitor

  • Początkujący
  • *
  • Wiadomości: 10
Odp: World of Tanks
« Odpowiedź #17 dnia: Sierpień 14, 2015, 01:51:24 pm »
Dobra udało się zainstalować, jednak jest problem z teksturami. W garażu nie widać czołgów, a na polu bitwy też jest czarny ekran widac tylko znaczniki i celownik.
« Ostatnia zmiana: Sierpień 14, 2015, 04:37:47 pm wysłana przez Pangenitor »

CameronPoe

  • SUSE Root
  • *****
  • Wiadomości: 1064
Odp: World of Tanks
« Odpowiedź #18 dnia: Sierpień 14, 2015, 10:10:31 pm »
A jaką masz kartę graficzną? Może zmiana sterowników pomoże, a jak nie, to możliwe, że nie masz czegoś dograne od Wine.
Jeżeli uruchomiłeś grę w trybie HD, to spróbuj zmienić i odpalić ją w SD.

Spróbuj w ostateczności wgrać grę tylko przez Wine (poza PlayOnLinux). Wpierw musisz pobrać skrypt winetricks z internetu, zapisać go do pliku o tej właśnie nazwie i we właściwościach zaznaczyć, aby był wykonywalny. Następnie w terminalu (będąc w katalogu tam gdzie jest ten plik) uruchom polecenie jako zwykły użytkownik:
winetricks d3dx9_36 vcrun2008 vcrun2010 corefonts msxml3 wininet ie7 ...w trakcie otworzy się przeglądarka i będziesz musiał pobrać msxml3 i go ręcznie dograć.

Potem dodaj jeszcze tamte dwie reguły i spróbuj wgrać grę od nowa na samym Wine, korzystając z wcześniej pobranych już plików aktualizacyjnych.

Pangenitor

  • Początkujący
  • *
  • Wiadomości: 10
Odp: World of Tanks
« Odpowiedź #19 dnia: Sierpień 15, 2015, 02:34:29 pm »
Zainstalowałem wot-a jeszcze raz od nowa i niby ruszyło. Mam jednak nadal dwa wkurzające problemy. Pierwszy (mniej wkurzający) nie widać emblematów na czołgach , są tylko czarne kwadraty. Drugi już bardziej że mnimapa jest jak by przeskalowana. Widać tylko jej powiększony fragment. Przez co nie zgadza się położenie pojazdów oraz punktów bazy i flagi.

CameronPoe

  • SUSE Root
  • *****
  • Wiadomości: 1064
Odp: World of Tanks
« Odpowiedź #20 dnia: Sierpień 15, 2015, 02:52:42 pm »
Kłopot z minimapą występuje na sterowniku otwartym od grafiki, więc zainstaluj sterownik zamknięty i będziesz miał po kłopocie (emblematy możliwe że też zaczną być poprawnie wyświetlane)  :thumleft:

Pangenitor

  • Początkujący
  • *
  • Wiadomości: 10
Odp: World of Tanks
« Odpowiedź #21 dnia: Sierpień 15, 2015, 06:21:45 pm »
No to chyba nic z tego nie będzie, ponieważ mam starą grafę HD4850 a z tego co znalazłem to dla niej nie ma zamkniętych sterowników.

CameronPoe

  • SUSE Root
  • *****
  • Wiadomości: 1064
Odp: World of Tanks
« Odpowiedź #22 dnia: Sierpień 15, 2015, 08:08:29 pm »
Powiedz mi, co Ci zaszkodzi spróbować? Wgranie sterowników to rzecz prosta - masz do wyboru gotowe paczki RPM z repozytorium społeczności lub prościutki skrypt z oficjalnej strony AMD (te drugie są chyba pewniejsze i możesz pobrać starszą wersję sterowników ze stronki http://support.amd.com/en-us/download/desktop/previous?os=Linux%20x86) :thumleft:

P.S.: Nie wierz we wszystko co piszą lub jak czegoś nie widzisz to nie znaczy, że tego nie ma ;)
« Ostatnia zmiana: Sierpień 15, 2015, 08:13:36 pm wysłana przez CameronPoe »

Pangenitor

  • Początkujący
  • *
  • Wiadomości: 10
Odp: World of Tanks
« Odpowiedź #23 dnia: Sierpień 15, 2015, 09:02:04 pm »
Spróbowałem zainstalować kilka z podanego linku, jednak za każdym razem instalator się wywala że ta karta nie jest obsługiwana przez te sterowniki. A w rpm nie mam pojęcia jak je odszukać. Sorki ale od nie dawna siedzę na tym systemie.

CameronPoe

  • SUSE Root
  • *****
  • Wiadomości: 1064
Odp: World of Tanks
« Odpowiedź #24 dnia: Sierpień 15, 2015, 09:31:13 pm »
Nie obraź się, ale chyba coś kręcisz. Przecież są tam do wyboru sterowniki do Radeona HD. Może nie umiesz poszukać lub wgrywasz nie te co trzeba. Jest różnica między karta nieobsługiwana, a system nieobsługiwany. Prześlij dowód Twojego stwierdzenia, czyli np. zrzut ekranu, gdzie pisze jakie stery wgrywasz i jaki błąd wyskakuje.
« Ostatnia zmiana: Sierpień 15, 2015, 09:41:23 pm wysłana przez CameronPoe »