forum.suse.pl

Informacje ogólne => Administracja => Wątek zaczęty przez: Atom w Lipiec 16, 2018, 06:30:45 am

Tytuł: Piekło zależności
Wiadomość wysłana przez: Atom w Lipiec 16, 2018, 06:30:45 am
Witam
Chciałbym znowu powrócić do SUSE. Chciałbym się dowiedzieć jak poprawnie użytkować system by nie wpaść w te piekło zależności które mnie bardzo mocno odstrasza. Podam przykład.
Świerzo zainstalowany system. Instalacja kodeków i już trzeba wybierać pomiędzy jakimiś bibliotekami. Z czasem było jeszcze ciekawiej. Po 3 miesiącach użytkowania zwykła aktualizacja i siedzisz wybierasz wersje zlewności. Doszło do tego że 5 minut przy zwykłym update zajmowało mi klikanie jaką wersję biblioteki potrzebuję. Bo na dysku jest taka a w update tej inna i tak dalej. Jak zmusić system by aktualizował się normalnie i nie doprowadzić do tego że zypper nic nie zaktualizuje bez mojej ingerencji. W takich dystrybucjach jak Debian, Arch itp nie miałem takich dziwnych problemów.
Tytuł: Odp: Piekło zależności
Wiadomość wysłana przez: szwagier w Lipiec 16, 2018, 02:21:00 pm
W Suse nie ma żadnych problemów z zależnościami. Są wyłącznie wtedy gdy dołożysz jakieś repozytoria z mało stabilnymi pakietami i zgodzisz się na zmianę dostawcy.
Na repozytoriach systemowych oraz społecznościowych zero problemu z zależnościami i bezproblemowe aktualizacje.
Instalacja kodeków nie wymaga zmiany zależności tylko zgody na zmianę dostawcy, bo multimediami rządzi repo Packmana a nie Suse.
Raz zainstalujesz i spokój. A jeszcze lepiej po instalacji wybierasz w Yast repo Packmana i przełączasz pakiety systemowe. Wtedy multimedia działają bezproblemowo i aktualizacje również.
Tytuł: Odp: Piekło zależności
Wiadomość wysłana przez: Atom w Lipiec 16, 2018, 03:37:09 pm
No właśnie tak robiłem i ciągle krzyczał że w repo Packmana są lepsze i nowsze. Ok spróbuje jeszcze raz. Ostatnie moje pytanie jaka wersja lepsza Leap czy Tumbleweed. Czy raczej różnice są tylko w tym że pakiety nie są aż tak przetestowane jak w wersji Leap ?
Tytuł: Odp: Piekło zależności
Wiadomość wysłana przez: szwagier w Lipiec 16, 2018, 04:11:24 pm
Instalacja kodeków
http://opensuse-guide.org/codecs.php
Polecam metodę konsolową. Klepiesz zawsze jedynki jako zgoda na zmianę dostawcy i na końcu yes.
Tombleweed jest dla bardziej doświadczonych userów bo lubi czasem fiknąć. Wiadomo - najnowsze pakiety i nie zawsze dobrze sprawdzone. Wtedy trzeba wracać do starszych bibliotek. Ale zawsze ma najnowszy kernel.
Tytuł: Odp: Piekło zależności
Wiadomość wysłana przez: Marcysia_Z w Lipiec 16, 2018, 07:22:02 pm
......
Tombleweed jest dla bardziej doświadczonych userów bo lubi czasem fiknąć. Wiadomo - najnowsze pakiety i nie zawsze dobrze sprawdzone. Wtedy trzeba wracać do starszych bibliotek. Ale zawsze ma najnowszy kernel.

Jeżeli można się wtrącić: Jak wyszła 15-ka to miałam problemy z kodekami (odtwarzany film zamrażał mi cały system i tylko twardy reset pomagał - o czym piszę w innym poście). wtedy od razu zainstalowałam Tumbleweed na dwóch urządzeniach i jak na razie nic mi nie fika :-) Aktualizacje wychodzą dosyć często a niektóre  mają nawet po 300 i więcej pakietów, i bardzo często kernel jest aktualizowany, a stary usuwany. Mimo częstych aktualizacji kernela sterowniki nvidii jeszcze mi ani razu nie padły. Czasem mi się wydaje, że jest odwrotnie - że to na 15-ce eksperymentują :-D